Scrigroup - Documente si articole

Username / Parola inexistente      

Home Documente Upload Resurse Alte limbi doc  

AccessAdobe photoshopAlgoritmiAutocadBaze de dateCC sharp
CalculatoareCorel drawDot netExcelFox proFrontpageHardware
HtmlInternetJavaLinuxMatlabMs dosPascal
PhpPower pointRetele calculatoareSqlTutorialsWebdesignWindows
WordXml

AspAutocadCDot netExcelFox proHtmlJava
LinuxMathcadPhotoshopPhpSqlVisual studioWindowsXml

Configuring the NM-NAM: Example

linux

+ Font mai mare | - Font mai mic




DOCUMENTE SIMILARE

Trimite pe Messenger
login linux command
lprm linux command
echo linux command
ldd linux command
fetchmail linux command
Electronic Mail
cpp linux command
identd linux command
klogd linux command
namei linux command


Configuring the NM-NAM: Example

In the following example, the external NAM interface is used for management traffic. The HTTP server and Telnet access are enabled. The resulting NAM CLI prompt isroot@nam1.company.com#.


ip address 172.20.105.215 255.255.255.192

ip host 'nam1'

ip domain 'company.com'

ip gateway 172.20.105.210

ip broadcast 10.255.255.255

ip nameserver 209.165.201.29

ip interface external

ip http server enable

exsession on

Checking Network Connectivity with Ping: Example




root@nam1.company.com# ping 172.20.105.213

PING 172.20.105.213 (172.20.105.213) from 172.20.105.215 : 56(84) bytes of data.
64 bytes from 172.20.105.213: icmp_seq=0 ttl=255 time=353 usec
64 bytes from 172.20.105.213: icmp_seq=1 ttl=255 time=289 usec
64 bytes from 172.20.105.213: icmp_seq=2 ttl=255 time=284 usec
64 bytes from 172.20.105.213: icmp_seq=3 ttl=255 time=283 usec
64 bytes from 172.20.105.213: icmp_seq=4 ttl=255 time=297 usec

--- 172.20.105.213 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max/mdev = 0.283/0.301/0.353/0.028 ms
root@nam1.company.com#

Sample Output for the show ip NAM CLI Command

root@nam1.company.com# show ip

IP address: 172.20.105.215
Subnet mask: 255.255.255.192
IP Broadcast: 10.255.255.255
IP Interface: External
DNS Name: nam1.company.com
Default Gateway: 172.20.105.210
Nameserver(s): 209.165.201.29
HTTP server: Enabled
HTTP secure server: Disabled
HTTP port: 80
HTTP secure port: 443
TACACS+ configured: No
Telnet: Enabled
SSH: Disabled
root@nam1.company.com#

Configuring a Static Route to the NAM Through the Analysis-Module Interface: Example

In the following example, a static route is configured to the NAM whose system IP address is 172.20.105.215. The NM-NAM is installed in router slot 1.


ip route 172.20.105.215 255.255.255.192 analysis-module 1/0

interface FastEthernet 0/0
 ip address 209.165.202.129 255.255.255.224
 no shutdown

interface Analysis-Module 1/0
 ip unnumbered FastEthernet 0/0
 no shutdown

Verifying Network Connectivity with Ping: Example

In the following example, entering the ping command verifies network connectivity to the NAM with IP address 172.20.105.215.

Router# ping 172.20.105.215

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.20.105.215, timeout is 2 seconds:

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Router#

Enabling NAM Packet Monitoring: Example

In the following example, NAM packet monitoring is enabled on the serial interfaces:

interface Serial 0/0
ip address 172.20.105.213 255.255.255.240
ip route-cache flow
speed auto
full-duplex
analysis-module monitoring
no mop enabled

interface Serial 0/1
ip address 172.20.105.53 255.255.255.252
ip route-cache flow
duplex auto
speed auto
analysis-module monitoring

interface Analysis-Module 2/0
ip address 10.1.1.1 255.255.255.0
hold-queue 60 out

Enabling the NAM Traffic Analyzer: Example

root@nam1# ip http server enable
Enabling HTTP server

No web users are configured.
Please enter a web administrator user name [admin]: <cr>
New password: <pswd>
Confirm password: <pswd>

User admin added.
Successfully enabled HTTP server.
root@nam1#

Accessing the NAM Traffic Analyzer: Example

Figure 6 shows the NAM Traffic Analyzer login window that appears when you enter the NAM system IP address or hostname as the URL in a web browser.

Figure 6 Sample NAM Traffic Analyzer Login Window

Changing the NAM Root Password: Example

root@nam1.company.com# password root
Changing password for user root
New UNIX password: <rtpswd>
Retype new UNIX password: <rtpswd>
passwd:all authentication tokens updated successfully
root@nam1.company.com#
root@nam1.company.com# exit

Verifying the NAM Root Password: Example

nam1.company.com login: root
Password: <rtpswd>
Terminal type: vt100

Cisco Network Analysis Module (NM-NAM) Console, 3.2
Copyright (c) 1999-2003 by cisco Systems, Inc.

root@nam1.company.com#
root@nam1.company.com# exit

Resetting the NAM Root Password to the Default Value: Example

Router# service-module analysis-module 1/0 reload
Do you want to proceed with reload?[confirm] y
Trying to reload Service Module Analysis-Module1/0.

Router# service-module analysis-module 1/0 session
Trying 172.20.104.87, 2033 Open

<debug output omitted>

Booting from flash, please wait.

[BOOT-ASM]


Please enter '***' to change boot configuration: ***

ServicesEngine Bootloader Version :1.0.6aN

ServicesEngine boot-loader> boot flash

<debug output omitted>


Cisco Systems, Inc.
Services engine helper utility for NM-NAM
Version 1.1(1) [200311111641]


Main menu
1 - Download application image and write to HDD
2 - Download application image and reformat HDD
3 - Download bootloader and write to flash
4 - Download helper and write to flash
5 - Display software versions
6 - Reset application image CLI passwords to default
7 - Change file transfer method (currently ftp/http)
8 - Show upgrade log
9 - Send Ping
r - Exit and reset Services Engine
h - Exit and shutdown Services Engine

Selection [123456789rh]: 6
Restored default CLI passwords of application image.

Cisco Systems, Inc.
Services engine helper utility for NM-NAM
Version 1.1(1) [200311111641]


Main menu
1 - Download application image and write to HDD
2 - Download application image and reformat HDD
3 - Download bootloader and write to flash
4 - Download helper and write to flash
5 - Display software versions
6 - Reset application image CLI passwords to default
7 - Change file transfer method (currently ftp/http)
8 - Show upgrade log
9 - Send Ping
r - Exit and reset Services Engine
h - Exit and shutdown Services Engine

Selection [123456789rh]: r
About to exit and reset Services Engine.
Are you sure? [y/N] y
INITSending all processes the TERM signal
Sending all processes the KILL signal
Unmounting file systems:
Please stand by while rebooting the system
Restarting system.

<debug output omitted>

Cisco Network Analysis Module (NM-NAM)

nam1.company.com login: <suspend keystroke>
Router#
Router# disconnect
Closing connection to 10.1.1.1 [confirm] <Enter>
Deleting login session

NAM Management Interface Is Internal and Analysis-Module Interface Is Assigned an IP Address: Example

In this configuration example:



The internal NAM interface is used for management traffic.

IP addresses from the same routable subnet are assigned to the Analysis-Module interface and the NAM system.

A static route to the NAM through the Analysis-Module interface is configured.

The internal NAM interface is used to monitor WAN traffic on interface Serial 0/0, and the external NAM interface is used to monitor LAN traffic on interface Fast Ethernet 0/0.

  The NM-NAM is installed in router slot 2.

Figure 7 shows the topology used in the example, and the following sections show the router and NAM configurations:

Router Configuration (Cisco IOS Software)

NAM Configuration (NAM Software)

Figure 7 NAM Management Interface Is Internal and Analysis-Module Interface Is Assigned an IP Address: Sample Topology

Callout

Interface

Location

Analysis-Module interface

Router internal

Internal NAM interface (management)

NM-NAM internal

External NAM interface

NM-NAM faceplate

Serial interface

WAN interface card (WIC)

Fast Ethernet interface

Router rear panel

Router Configuration (Cisco IOS Software)


ip cef

ip route 209.165.200.226 255.255.255.224 analysis-module 2/0

interface FastEthernet0/0
ip address 209.165.202.129 255.255.255.224
ip route-cache flow
speed auto
full-duplex
no mop enabled
no shutdown

interface Serial 0/0
encapsulation ppp
ip address 209.165.201.1 255.255.255.224
analysis-module monitoring
no shutdown

interface analysis-module 2/0
ip address 209.165.200.225 255.255.255.224
hold-queue 60 out
no shutdown

NAM Configuration (NAM Software)


ip address 209.165.200.226 255.255.255.224

ip host 'nam1'

ip domain 'company.com'

ip gateway 209.165.200.225

ip broadcast 10.255.255.255

ip nameserver 172.16.201.29

ip interface internal

ip http server enable

exsession on

NAM Management Interface Is Internal and Analysis-Module Interface Is IP Unnumbered: Example

In this configuration example:

The internal NAM interface is used for management traffic.

IP addresses from the same routable subnet are assigned to the Analysis-Module interface and the NAM system.

  To conserve IP address space, the Analysis-Module interface is configured as IP unnumbered to borrow the IP address of the Fast Ethernet interface.

A static route to the NAM through the Analysis-Module interface is configured.

The internal NAM interface is used to monitor WAN traffic on interface Serial 0/0, and the external NAM interface is used to monitor LAN traffic on interface Fast Ethernet 0/0.

The NM-NAM is installed in router slot 2.

Figure 8 shows the topology used in the example, and the following sections show the router and NAM configurations:

Router Configuration (Cisco IOS Software)

NAM Configuration (NAM Software)

Figure 8 NAM Management Interface Is Internal and Analysis-Module Interface Is IP Unnumbered: Sample Topology

Callout

Interface

Location

Analysis-Module interface

Router internal

Internal NAM interface (management)

NM-NAM internal



External NAM interface

NM-NAM faceplate

Serial interface

WAN interface card (WIC)

Fast Ethernet interface

Router rear panel

Router Configuration (Cisco IOS Software)


ip cef

ip route 209.165.200.226 255.255.255.224 analysis-module 2/0

interface FastEthernet0/0
ip address 209.165.200.225 255.255.255.224
ip route-cache flow
speed auto
full-duplex
no mop enabled
no shutdown

interface Serial 0/0
encapsulation ppp
ip address 209.165.201.1 255.255.255.224
analysis-module monitoring
no shutdown

interface analysis-module 2/0
ip unnumbered FastEthernet0/0
no shutdown
hold-queue 60 out

NAM Configuration (NAM Software)


ip address 209.165.200.226 255.255.255.224

ip host 'nam1'

ip domain 'company.com'

ip gateway 209.165.200.225

ip broadcast 10.255.255.255

ip nameserver 172.16.201.29

ip interface internal

ip http server enable

exsession on

NAM Management Interface Is External and Analysis-Module Interface Is IP Unnumbered: Example

In this configuration example:

The external NAM interface is used for management traffic.

The Analysis-Module interface is configured as IP unnumbered to borrow the IP address of the loopback interface.

  The borrowed loopback interface IP address is not routable.

The NAM system is configured with an IP address from the LAN subnet that is connected to the external NAM interface.

The internal NAM interface is used to monitor WAN traffic on interface Serial 0/0, and the external NAM interface is used to monitor LAN traffic on interface Fast Ethernet 0/0.

  The NM-NAM is installed in router slot 3.

Figure 9 shows the topology used in the example, and the following sections show the router and NAM configurations:

Router Configuration (Cisco IOS Software)

NAM Configuration (NAM software)

Figure 9 NAM Management Interface Is External and Analysis-Module Interface Is IP Unnumbered: Sample Topology

Callout

Interface

Location

Analysis-Module interface

Router internal

Internal NAM interface

NM-NAM internal

External NAM interface (management)

NM-NAM faceplate

Loopback interface

Router internal

Serial interface

WAN interface card (WIC)

Fast Ethernet interface

Router rear panel

Router Configuration (Cisco IOS Software)


ip cef

interface loopback 0
ip address 10.1.1.1 255.255.255.0

interface FastEthernet0/0
ip address 209.165.201.1 255.255.255.224
ip route-cache flow
speed auto
full-duplex
no mop enabled
no shutdown

interface Serial 0/0
encapsulation ppp
ip address 209.165.202.129 255.255.255.224
analysis-module monitoring
no shutdown

interface analysis-module 3/0
ip unnumbered loopback 0
hold-queue 60 out
no shutdown

NAM Configuration (NAM software)


ip address 209.165.201.2 255.255.255.224

ip host 'nam1'

ip domain 'company.com'

ip gateway 209.165.201.1

ip broadcast 10.255.255.255

ip nameserver 209.165.201.29

ip interface external

ip http server enable

exsession on






Politica de confidentialitate



DISTRIBUIE DOCUMENTUL

Comentarii


Vizualizari: 1100
Importanta: rank

Comenteaza documentul:

Te rugam sa te autentifici sau sa iti faci cont pentru a putea comenta

Creaza cont nou

Termeni si conditii de utilizare | Contact
© SCRIGROUP 2021 . All rights reserved

Distribuie URL

Adauga cod HTML in site